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1 OVERVIEW

Introduction: 

The Windows-based Label Creator software enables the user to create new labels for controller
or to load existing labels from the controller onto the computer and edit them. The edited
labels can then be loaded back to controller.

All label settings can be set in the Creator software and saved together with the label. 

Wolke Label Creator allows the user to import and edit legacy labels. Labels will be saved as
either *.xml (UTF-8 or ASCII (CP-1252)) or *.lbl (A.1.23) (ASCII) files by choosing the
required extension. The controller will accept labels from A.1.17 to A.1.23 (ASCII) or XML
(UTF-8).

The label creator will transfer files to both m600 advanced and m600 OEM controllers. 

NOTE
On opening a *.lbl file from a software version older than A.1.23, an alert
message will be raised, indicating that the label will be stored in *.lbl (A.1.23)
or *.xml (ASCII (CP-1252)) format.

NOTE
m600 advanced transfer will not allow selected font list or machine settings
to be exchanged.
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The graphical representation of label file compatibility is shown below:

Fig. 1_1: Information while Converting a File

Firmware Version: 

This is the operating system which is installed on the controller. The firmware version
currently installed is visible on the Version Numbers screen of the controller.
Wolke Label Creator
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2 INSTALLATION

2.1  Prerequisites – System Requirements

Operating System: 

• Windows XP
• Windows 7
• Windows 8

Only an Administrator can install the m600 Label Creator software.

Hardware: 

• Network Interface Card.

The screen resolution should be at least 800 x 600 pixels with a colour depth of 16 bit.

2.2 Installing the Wolke Label Creator

Do the following tasks to install the Wolke Label Creator:

1. Run the Label Creator setup file from the software package provided.
2. The Welcome screen will appear as shown in the figure. Follow the instructions 

mentioned on the screen and click on the Next button.

Fig. 2_2: Welcome Screen
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3. Continue to follow the instructions as the installation wizard guides through language 
selection, license agreement, user information, installation folder, and shortcut folder 
setup. Click on the Next button.

4. The user will be prompted with Ready to Install window as shown in the figure. Click 
on Next to install the Label Creator.

Fig. 2_3: Ready to Install Screen

5. The installation of Label Creator will start.

NOTE
The user can also change the location of installation folder by either typing
the new path or by clicking on the change button to browse for an existing
folder.

NOTE
The user can also change the location of shortcut folder by either typing the
new name or by selecting the existing folder from the dropdown list.

NOTE
If a previous version of the label creator is detected on the PC, the user will
be requested if the older version is to be removed prior to continuing the
installation.
Wolke Label Creator
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6. Click on the Finish button after successful installation of the Label Creator.

Fig. 2_4: Installation Successful Screen

Unless a different path is selected for software installation, the software is installed in the
program directory in the folder “C:\Program Files (x86)\Wolke\m600 oem\ Label Creator”.

The user can start the Wolke Label Creator via “Start >> All Programs >> Wolke >> 
Label Creator”. The login details window opens, the user can select the user type for log on
and enter the password to login.

Fig. 2_5: Login

NOTE
For initial log in: User = admin, Password = admin.
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3 CREATOR WINDOW

Fig. 3_6: Wolke Label Creator Window

The fundamental design of the Creator window is subdivided into several display and 
processing ranges. 

• Main menu
• Toolbar
• Editor window
• Object directory
• Mode information

1 2

3

1. Main Menu 4. Editor Window

2. Toolbar 5. Object Directory
3. Mode

5 4
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3.1 Main Menu

An important area is the main menu which, in conjunction with the individual toolbars, enables
fundamental operation of the Creator. Toolbars can be arranged as required by the operator.
The following text describes the structure of the main menu.

3.1.1 File

Fig. 3_7: File Menu

New: Allows the user to create new label.
Open: Allows the user to open the saved labels.
Load from controller: Allows the user to load a label from the controller.
Upload to controller: Allows the user to upload a label to the controller.
Convert legacy labels to oem: Allows the user to convert legacy label or bitmap files stored on the PC.
Save: Allows the user to save the current label with the same name.
SaveAs: Allows the user to save the current label with a new name.
1// C:/Label-1.xml: Allows the user to open the last opened files (max. 5).
Print: Allows the user to print the current label on a Windows printer.
Close: Allows the user to close the Editor Window.
Exit: Allows the user to exit from the Creator software.

3.1.2 Edit

Fig. 3_8: Edit Menu

NOTE
Load from controller and Upload to controller options are greyed out
until controller is connected via Settings.

Undo: Allows the user to undo the last few actions.
Redo: Allows the user to redo the last few actions which were undone.
Cut: Allows the user to cut objects and put them into the clipboard.
Copy: Copies the selected object to clipboard.
Paste: Pastes the contents of clipboard onto the label.
Delete selected: Deletes the selected object from the label.
Delete all: Deletes all the objects from the label.
Label settings: Opens the Label settings window.
Wolke Label Creator
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3.1.3 Insert

Fig. 3_9: Insert Menu

3.1.4 View

Fig. 3_10: View Menu

3.1.5 Settings

NOTE
If a controller is connected when the mode selected is changed, the user will
be reminded that continuing will disconnect the controller. All open label
windows will be closed. 

Text: Allows the user to insert the text field in the label.
Date: Allows the user to insert the date field in the label.
Time: Allows the user to insert the time field in the label.
Shift: Allows the user to insert the shift field in the label.
Counter: Allows the user to insert the counter field in the label.
Combi: Allows the user to insert the combi field in the label.
Bitmap: Allows the user to insert the bitmap object in the label.
Barcode: Allows the user to insert different barcode object in the
label.

Zoom-In: Allows the user to upsize the label view.
Zoom-Out: Allows the user to downsize the label view.
Object directory: Allows the user to see the items used in the
label.

Connect to controller: Opens window for setting
connection to a controller.
Open local settings: Opens window for local label settings.
Open m600_oem settings: Opens m600_oem settings
window to allow settings to be viewed and updated for the
connected controller.
ASCII mode: Open m600_oem settings not available. 
Change password: Allows the user to change the
password.
Select language: Allows the user to select the required
language. The language selected now is immediately
transferred to the program.
Select mode: Allows the user to select the required mode.Fig. 3_11: Settings Menu
Wolke Label Creator
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3.1.6 Windows

Fig. 3_12: Window Menu

3.1.7 Help

Fig. 3_13: Help Menu

3.2 Toolbar 
All icons used in the main menu also appear in the toolbar with identical functions.

3.3 Mode information
The current mode of the Label Creator is displayed. User can switch between UTF-8 or ASCII
mode by clicking on the displayed mode. 

Fig. 3_14: Mode Information

Displays the icons for the File menu options.

Displays the icons for the Edit and View menu options.

Displays the icons for the Insert menu options.

Displays the barcode options.

Displays the icons to switch the editor window between
Tile and Cascaded.

Cascaded: Allows the user to arrange the windows in a
superimposed fashion.
Tile: Allows the user to arrange the windows side by side.

User manual: Opens the Label Creator manual.
About: Opens About Label Creator window.
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3.4 Editor window
The objects in the label are displayed in the Editor window. 

Fig. 3_15: Editor Window

3.5 Object Directory
The object directory shows all objects within one label. By clicking on a directory item, the
object in question is selected and highlighted in the label view.

Fig. 3_16: Object Directory
Wolke Label Creator
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4 LEGACY FILE CONVERTER

Convert legacy labels to oem option is selected from the File menu:

Fig. 4_17: Legacy File Converter

Convert legacy labels to oem option allows the user to convert legacy label or bitmap files
to XML (UTF-8). The converter can convert a single file or multiple files at the same time. Files
can be selected either with the same or different extensions (*lbl and *xml) as required for
conversions at the same time. 

Label files in XML (UTF-8) format will not be converted and appear as blue text after
conversion.

Fig. 4_18: Legacy File Converter - XML Format
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Label files not in XML (UTF-8) format will appear as red text after conversion.

Fig. 4_19: Legacy File Converter - not in XML Format

The Select font package displays the available font packages on the PC that can be selected
for conversion. 

Fig. 4_20: Legacy File Converter - Font Package

NOTE
If the requested font package does not contain the font map, the font style
will use the default dejavu sans normal.
Wolke Label Creator
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5 LABEL SETTINGS

Label settings option is selected from the Edit menu: 

Fig. 5_21: Edit Menu

5.1 Label Settings

Label settings option allows the user to edit the label and change the output print settings.
All settings made to the label, applies only to the current label and are saved together with
the label data and transferred onto the controller during upload.

Fig. 5_22: Label Setup

The various options available for the label settings are described below:

5.1.1 Size and Resolution

Size and Resolution window allows the user to set the Size and Grouping details - number
of print heads, group printheads and set the nozzle row. Dynamic Print Intensity allows
different DPI resolutions to be set for bar codes and text within one printhead, optimizing ink
consumption.

Fig. 5_23: Label Setup - Size and Resolution
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The various options available are described in the below table:

No of print
heads

Set the number of printheads required to print the
image. The number of printheads range from 1-6.

Grouping

• all individually - Each head prints different 
data within a job. If this setting is selected, 
whenever you create a new job you will be 
given exactly the number of print fields that 
were set in the Number of printheads.

• all like head 1 - All the printheads print the 
same data as head 1. In this setting, only one 
print field is made available. The text entered 
here applies automatically to all the heads 
which were predefined for this job in the 
Number of printheads.

• head 3/4 like 1/2 - Heads 3 and 4 print the 
same data as heads 1 and 2. In this case only 
two fields will be available for entering the 
print data. The text entered here applies 
equally to heads 1/2 and 3/4.

• head 5/6, 3/4 like 1/2 - Heads 5 and 6, 3 
and 4 print the same data as heads 1 and 2. In 
this case only two heads will be available for 
entering the print data. The text entered here 
applies equally to heads 1/2 and 3/4 and 5/6.

• head 4/5/6, like 1/2/3 - Heads 4, 5 and 6 
print the same data as heads 1, 2 and 3. In this 
case only three heads will be available for 
entering the print data. The text entered here 
applies equally to heads 1/2/3 and 4/5/6.

Nozzle row

The ink cartridge has two nozzle rows. The printer
can be setup to print with both nozzle rows or only
one nozzle row (left/right). Set “both” to print with
maximum resolution.
The resolution is 300 dpi with the left or the right
nozzle row and 600 dpi with both the nozzle rows.

Resolution
This sets the horizontal resolution. This setting
specifies the dpi for the label used during printing in
the direction of movement of the product.

Reduced
Resolution

This option allows a reduced resolution (dpi) to be set
for use with certain objects (e.g. text) in a label.
When selected for an object, the object is printed at
a reduced resolution (increasing ink consumption
optimization) rather than the defined label
resolution. 
To use reduced resolution, a selection button is made
available in the eligible objects field properties which
allows reduced resolution to be used with that object.
Refer to “INSERTING OBJECTS” on page 19 for
additional details.
Wolke Label Creator
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5.1.2 Label Dimensions

Label dimension is used to set the dimensions and label distances for printing contrary to
the preferred direction. The Label dimension window is shown in the below figure:

Fig. 5_24: Label Setup - Label Dimensions

The various options available to set the label dimensions are described in the below table.

Dist. Before
The distance (in mm) between the beginning
of the product and the beginning of the
printing area.

Dist. After The distance (in mm) between the end of the
printing area and the end of the product.

Rev Dist. Before

The reverse distance (in mm) between the
beginning of the product and the beginning of
the printing area.
Note: Reverse printing permits printing in
both directions of movement.

Rev Dist. After The reverse distance (in mm) between the end
of the printing area and the end of the product.
Wolke Label Creator
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5.1.3 Additional Settings

Additional settings provides options to set the parameters for the output of labels.

Fig. 5_25: Label Setup - Additional Settings

Print Length The print length is the length of the job.

NOTE

In Additional settings, Buffer overflow is not available in the ASCII mode.
Wolke Label Creator
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The various options available for the additional settings are described in the table below:

Autostart
If the label with active Autostart was in print
memory before repowering the printer, the
printer will automatically start.

Limit output
Defines the number of jobs that are permitted
to be in the Job queue. Limit count is a setup
parameter for Limit output.

Cyclic Defines the counter per sensor signal. Count/
Sensor is a setup parameter for Cyclic.

Show Bitmap Displays bitmaps.

Limit count Defines the number of prints that will be done
if Limit output is activated.

Count/Sensor

Defines the amount of prints which will be
done when triggered once. If the value is set
to “0”, the printer will print as long as the
printer sensor is high.

Variable Mode

The variable mode is used to supply variable
fields with data from an external source
(serialization of the print data).
In once buffered mode, the variable data
record provided by the host controller is
printed only once. If no more data in the print
buffer, the printer will wait untill the new data
is transferred from the host controller into the
print buffer. The host controller can send
multiple variable data sets prior to or during
prints.
In continuous mode, a data record is printed
repeatedly, until a new data record is
transferred.
In once unbuffered mode, the host controller
will send variable data for the next print. Once
the print is complete, the variable data for the
following print is sent.

Buffer
Overflow

Set the actions for buffer overflow conditions
from the dropdown list. This is required when
more sets of data are sent than permitted.

• Add and Respond- Allows to add job 
after the maximum permitted number of 
jobs in the queue has been reached.

• Reject and Respond - Rejects the job 
after the maximum permitted number of 
jobs in the queue has been reached.

• Overwrite - Overwrites the already 
sent data set on the printer.

• Add, Respond and Warn - Allows the 
user to add job after the maximum 
permitted number of jobs in the queue 
has been reached and warns the user 
about the buffer overflow.

• Reject and Generate Error - Rejects 
the job after the maximum permitted 
number of jobs in the queue has been 
reached and generates error.
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5.1.4 Spitting Settings

Fig. 5_26: Spitting Settings

The spitting is carried out at timed intervals when the printhead is powered on but not
printing. The user can set the length of purge and the time interval for timed printing.
If the printhead is powered on and has not been printing, the printhead will purge once it
reaches the inactivity period of time defined by the user. The function can also be deactivated.

Status Allows the user to activate or deactivate the
purge

Pause Idle time for the printhead to purge. It is the
time interval between purges.

Distance The distance between the printer trigger and
the start of the purge.

Length The length of the purge. The user can set the
length and time for spitting activated.

Spitting
without
encoder 

Spitting is trigered by a seperate input/
photocell. No speed signal is required.
Wolke Label Creator
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6 INSERTING OBJECTS

To create a label, objects can be inserted. The various options available in the Insert menu
are shown below:

Fig. 6_27: Insert Menu

The object properties window opens when inserting the object in the label.

NOTE
The respective object properties window opens when the object is double
clicked.

NOTE
The various fields can be printed with the orientation from left --> right and
right --> left as well as top -->bottom and bottom -->top.

NOTE
If reduced resolution has been set in label settings, where available, the
object properties window contains a drop down box for the required
resolution to be selected (default setting = resolution dpi).

Text: Allows the user to insert the text field in the label.
Date: Allows the user to insert the date field in the label.
Time: Allows the user to insert the time field in the label.
Shift: Allows the user to insert the shift field in the label.
Counter: Allows the user to insert the counter field in the label.
Combi: Allows the user to insert the combi field in the label.
Bitmap: Allows the user to insert the bitmap object in the label.
Barcode: Allows the user to insert different barcode object in
the label.
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6.1 Insert Text Field
Text field is used to insert the required text in the label. The text button is used for the
following:

• To enter the text contents in the input field.
• To set the field properties (text height, font type, style and stretch factor).
• To set the position and orientation of the text field in the label.
• To select the User Editable field, if the text object has to be edited by the user.
• To select the Variable field, to transfer data. For example, to transfer data directly from 

a database to the variable fields with the help of an interface command, and to print 
them immediately.

Fig. 6_28: Text Field Properties

6.1.1 Master Field

Master field window is used for the following:

• To link the text field to a master field.

Fig. 6_29: Master Field

NOTE
Only the PC installed TTF true type fonts can be used. The user has to select
the font from the available list.
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6.1.1.1 To Link to a Master Field

Do the following tasks to link the text field to a master field:
• Go to Master field window.
• Select Link to Master field option. The list of Master field and Master field value is 

displayed.
• Select the required master field and click OK.

Fig. 6_30: Link as Master Field
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6.2 Insert Date Field

Date field is used to insert the date as per the required format in the label. The various options
available to create and edit date fields are described below:

6.2.1 Date Field

Date field properties window is displayed when double-clicked on the date object inserted
in the label. Date field properties window is used for the following:

• To set the update mode and offset value.
• To set the date format.
• To select the user editable field, if the date object has to be edited by the user.
• To set the Forerun values (days/months/years).
• To set the field properties (text height, font type and style).
• To set the position and orientation of the date field in the label.

Fig. 6_31: Date Field Properties 
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6.2.2 Master Field

Master field window is used for the following:

• To link the date field to a master field.

Fig. 6_32: Date Field Properties - Master Field

6.2.2.1 To Link to a Master Field

Do the following tasks to link the date field to a master field:
• Go to Master field window.
• Select Link to Master field option. The list of Master field and Master field value is 

displayed.
• Select the required master field and click OK.
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6.2.3 User Defined Date Format

User defined date format option is used for the following:

• To create an individual date format by clicking on the key formats and special 
characters, and by entering text elements.

• To customize the date format more and to assign names for the days, months and days 
of the week via the tabs day codes, month codes and week-day codes.

• The individual format allows the user to customize the date format.
• The day, month and week-day codes allow the user to define the codes required within 

the label.

Fig. 6_33: Date Field Properties - User Defined Date Format

NOTE
For formatting an individual date format, you can first set a predefined
format, which is as similar as possible to the individual format, on the format
page. Formatting is transferred into the individual date format and can be
edited subsequently.
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6.3 Insert Time Field
Time field is used to insert the time in required format in the label. The time field properties
window is displayed when double-clicked on the time object inserted in the label.

6.3.1 Time Field Properties 

Time field properties are used for the following:

• To set the update mode and offset value.
• To set the time format and forerun values.
• To set the field properties (text height, font type and style).
• To set the position and orientation of the time field in the label.

Fig. 6_34: Time Field Properties – General Properties
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6.3.2 User Defined Time Format

User defined time format option is used for the following:

• To create an individual time format by clicking on the key formats and special 
characters, and by entering text elements.

Fig. 6_35: User Defined Time Format - Advanced Time Format

NOTE
For formatting an individual time format, you can first set a predefined
format, which is as similar as possible to the individual format, on the format
page. Formatting is transferred into the individual time format and can be
edited subsequently.
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• The hour codes allows the user to define the codes required for creating user defined 
formats.

Fig. 6_36: User Defined Time Format - Hour Codes
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6.4 Insert Shift Field

Shift field allows to insert the shift details in the label. The shift field properties window is
displayed when double-clicked on the shift field object inserted in the label.

6.4.1 Shift Field Properties 

Shift field properties window is used for the following:

• To set the number of shifts (maximum eight shifts).
• To set the display hour format.
• To enter the shift start time and shift code for all the shifts.
• To set the field properties (text height, font type and style)
• To set the position and orientation of the shift field in the label.

Fig. 6_37: Shift Field Properties
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6.5 Insert Counter Field

Counter field allows the user to insert the counter in the label. The counter field properties
window is displayed when double-clicked on the counter field object inserted in the label.

6.5.1 Counter Field Properties 

Counter field properties window is used for the following:

• To enter the counter value.
• To set the counter properties.
• To set the field properties (text height, font type, style and stretch factor)
• To set the position and orientation of the counter field in the label.

Fig. 6_38: Counter Field Properties - General Properties
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6.5.2 Advanced

Advanced option is used for the following:

• To format the batch counters.
• To set the action to be performed when the final value is reached.
• To activate the alarm once the final value is reached.

Fig. 6_39: Counter Field Properties - Advanced
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6.5.3 Master Field

Master field option is used for the following:

• To link the counter field to a master field.

Fig. 6_40: Counter Field Properties - Master Field

6.5.3.1 To Link to a Master Field

Do the following tasks to link the counter field to a master field:
• Go to Master field window.
• Select Link to Master field option. The list of Master field and Master field value is 

displayed.
• Select the required master field and click OK.
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6.6 Insert Combi Field

Combi field is used to insert multiple data in the label. The combi field properties window
is displayed when double-clicked on the combi field object inserted in the label.

6.6.1 Combi Field Properties 

General properties window is used for the following:

• To insert multiple fields.
• To insert text, date, time, counter and shift in the single field
• To merge fields

Fig. 6_41: Combi Field Properties
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6.7 Insert Bitmap

Bitmap properties window is displayed when double-clicked on the bitmap object inserted
in the label.

6.7.1 Bitmap Properties

• General properties option is used to select the required bitmap image, by clicking 

the  button.
• To set the position and orientation of the bitmap image in the label.

Fig. 6_42: Bitmap Properties

NOTE
The bitmap file must be saved in the same directory as the label.

This is the only way to represent the label completely when opening it
subsequently.

The bitmap file must be a black and white Windows bitmap with the colour
depth value one.
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6.8 Insert Barcode Object

The barcode properties window is displayed when double-clicked on the barcode object
inserted in the label.

6.8.1 Barcodes - EAN13, EAN8, UPC - A/E

For the barcode types EAN8, EAN13 and UPC-A/E, the checksum is calculated automatically.

6.8.1.1 General Properties

General Properties option is used for the following:

• To enter the barcode value.
• To set the field properties (red. of line width, height, scale factor).
• To set the position and orientation of the barcode object in the label.
• To select the User Editable field, if the barcode object has to be edited by the user.
• To highlight the Variable field, to transfer data. For example, to transfer data directly 

from a database to the variable fields with the help of an interface command, and to 
print them immediately.

Fig. 6_43: General Properties - EAN13, EAN8

NOTE
In case of the barcode types Code39, Code25i, Code128, EAN 128,
Datamatrix, GS1 Databar and QRcode, an embedded field may also be used
as value of the barcode. To enter the embedded field, click on the appropriate
icon. The editor window of the embedded field opens to enable editing. If a
barcode other than mentioned above has been selected, the icons are not
visible.

If an embedded field is inserted in the barcode contents, the object cannot
be edited by the User.

NOTE
The barcodes Codabar, Code39, Code 2/5i, Code128, EAN128, GS1 Databar,
Postnet, and IMB can only be printed with the orientation from left --> right
and right --> left.
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Fig. 6_44: General Properties - UPC - A/E

NOTE
The barcode UPC- A/E can be compressed to UPCE format.
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6.8.2 Codabar

For the barcode type Codabar the checksum can be calculated. To calculate checksum select
Calculate checksum option in the General properties window.

6.8.2.1 General Properties

General Properties window is used for the following:

• To enter the barcode value.
• To set the field properties (red. of line width, height, scale factor, bar ratio).
• To select Calculate checksum, if the checksum value has to be calculated.
• To set the position and orientation of the barcode object in the label.
• To select the User Editable field, if the barcode object has to be edited by the user.
• To highlight the Variable field, to transfer data. For example, to transfer data directly 

from a database to the variable fields with the help of an interface command, and to 
print them immediately.

Fig. 6_45: General Properties - Codabar
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6.8.3 Barcodes - Code39, Code25i

For the barcode types Code39, Code25i, the checksum can be calculated. To calculate
checksum select Calculate checksum option in the General properties window.

6.8.3.1 General Properties

General Properties window is used for the following:

• To enter the barcode value.
• To insert the dynamic fields (text, date, time, counter and shift code) in the barcode 

value field.
• To set the field properties (red. of line width, height, scale factor, bar ratio).
• To select Calculate checksum, if the checksum value has to be calculated.

• To set the position and orientation of the barcode object in the label.
• To select the User Editable field, if the barcode object has to be edited by the user.
• To highlight the Variable field, to transfer data. For example, to transfer data directly 

from a database to the variable fields with the help of an interface command, and to 
print them immediately.

Fig. 6_46: General Properties - Code25i

NOTE
The Code39 barcode field properties allow to include delimiter.
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6.8.3.2 Barcode Text

Barcode Text window is used for the following:

• To select the Show barcode text option, if the barcode value has to be displayed in the 
label.

• To set the position, font type and font style of the barcode value.
• To set the stretch factor, line spacing and text height of the barcode value.

Fig. 6_47: Barcode Text - Code25i
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6.8.4 Barcodes - Code128, Ean128

Auto scale property is available for the barcode types Code128, Ean128.

6.8.4.1 General Properties

General Properties window is used for the following:

• To enter the barcode value.
• To insert the dynamic fields (text, date, time, counter and shift code) in the barcode 

value field.
• To set the field properties (red. of line width, height, scale factor, module size, 

codelength, opt. codelength).
• To set the position and orientation of the barcode object in the label.
• To select the User Editable field, if the barcode object has to be edited by the user.
• To highlight the Variable field, to transfer data. For example, to transfer data directly 

from a database to the variable fields with the help of an interface command, and to 
print them immediately.

Fig. 6_48: General Properties - Code128
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6.8.4.2 Barcode Text

Barcode Text window is used for the following:

• To select the Show barcode text option, if the barcode value has to be displayed in the 
label.

• To set the position, font type and font style of the barcode value.
• To set the stretch factor, line spacing and text height of the barcode value.

Fig. 6_49: Barcode Text - Code128
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6.8.5 Datamatrix

6.8.5.1 General Properties

General Properties window is used for the following:

• To enter the barcode value.
• To insert the dynamic fields (text, date, time, counter and shift code) in the barcode 

value field.
• To set the field properties (type, matrix size, pixel reduction, module size and actual 

value).
• To set the position and orientation of the barcode object in the label.
• To select the User Editable field, if the barcode object has to be edited by the user.
• To highlight the Variable field, to transfer data. For example, to transfer data directly 

from a database to the variable fields with the help of an interface command, and to 
print them immediately.

Fig. 6_50: General Properties - Datamatrix
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6.8.6 GS1 Databar

6.8.6.1 General Properties

General Properties window is used for the following:

• To enter the barcode value.
• To insert the dynamic fields (text, date, time, counter and shift code) in the barcode 

value field.
• To set the field properties (linear code, pixel reduction, module size, actual value).
• To set the position and orientation of the barcode object in the label.
• To select the User Editable field, if the barcode object has to be edited by the user.
• To highlight the Variable field, to transfer data. For example, to transfer data directly 

from a database to the variable fields with the help of an interface command, and to 
print them immediately.

Fig. 6_51: General Properties - GS1 Databar
Wolke Label Creator
16 December 2016 Page 42 of 69 Revision AC



6.8.6.2 Barcode Text

Barcode Text window is used for the following:

• To select the Show barcode text option, if the barcode value has to be displayed in the 
label.

• To select the Show text 2D option, if the barcode value has to be displayed in 2D.
• To set the position, font type and font style of the barcode value.
• To set the stretch factor, line spacing and text height of the barcode value.

Fig. 6_52: Barcode Text - GS1 Databar
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6.8.7 QR Code

6.8.7.1 General Properties

Kanji mode and 8-Bit mode can be selected for QR code.

General Properties window is used for the following:

• To enter the barcode value.
• To insert the dynamic fields (text, date, time, counter and shift code) in the barcode 

value field.
• To set the field properties (Matrix size, pixel reduction, module size, actual value, and 

ECC level).
• To set the position and orientation of the barcode object in the label.
• To select the User Editable field, if the barcode object has to be edited by the user.
• To highlight the Variable field, to transfer data. For example, to transfer data directly 

from a database to the variable fields with the help of an interface command, and to 
print them immediately.

Fig. 6_53: General Properties - QR Code
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6.8.8 Barcodes - Postnet, IMB

6.8.8.1 General Properties

General Properties window is used for the following:

• To enter the barcode value.
• To set the field property, Red. of line width.
• To set the position and orientation of the barcode object in the label.
• To select the User Editable field, if the barcode object has to be edited by the user.
• To highlight the Variable field, to transfer data. For example, to transfer data directly 

from a database to the variable fields with the help of an interface command, and to 
print them immediately.

Fig. 6_54: General Properties - Postnet
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6.9 Positioning Objects

To move an object in the label, click on the object and draw it to the required place while
keeping the left mouse button pressed.

To position the object precisely, you can use the cursor coordinates in the label window's
status bar. To enhance positioning accuracy even further, move the object via the object
editor's X and Y menu.

Fig. 6_55: Positioning the Object via the Coordinates

6.9.1 Object Editor

To edit an object within a label - the user will double click on the object and the required
property box will appear. The object selected is shown in the label with a dotted box around it.

Fig. 6_56: Properties Window
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6.9.2 Editor Window

In the label display, the label being created is displayed with file name.
With the editor window maximized, the file name and the label version appear in the title bar
of the program.

Fig. 6_57: Editor Window

Rulers located on two sides are used to estimate the size proportions and to enable accurate positioning
of the objects. 
Two red marking lines show the current cursor position.
Current cursor position in the X and Y axes is also displayed precisely in the lower status bar. 

Fig. 6_58: Editor Window - Marking Lines and Cursor Positions

X-axis

Y-
ax

is
Wolke Label Creator
Revision AC Page 47 of 69 16 December 2016



The objects in the label can be grouped and aligned with respective to other objects. Select
the required objects and right-click to view the options:

Below example shows how to align two objects with the third object using the option Left
align with...:

Select the text field and the date field objects, and right click on it. Select the Left align
with... option.

Fig. 6_60: Editor Window - Left Align the Object

Click on the barcode object. The text field and the date field are now aligned with the left side
of the barcode.

Fig. 6_61: Left Aligned Objects

Left align with...: Select the object(s) to be aligned, then
select Left align with... by right clicking once selected and
select the object to be aligned with.
Right align with...: Select the object(s) to be aligned, then
select Right align with... by right clicking once selected and
select the object to be aligned with.
Top align with...: Select the object(s) to be aligned, then
select Top align with... by right clicking once selected and
select the object to be aligned with.
Bottom align with...:Select the object(s) to be aligned,
then select Bottom align with... by right clicking once
selected and select the object to be aligned with.

Fig. 6_59: Editor Window - Align Objects
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7 GENERAL SETTINGS

7.1 Creating a Label
In the below section the user is guided to create a label which consists of the following fields:

• One text field
• One date field
• One barcode
• One bitmap

Fig. 7_62: Sample Label - Fields in Object Editor
Wolke Label Creator
Revision AC Page 49 of 69 16 December 2016



7.1.1 Creating a New Label

To create a new label, do one of the following:
1. Select File > New in the main menu.
2. Click on the button New in the toolbar.

As default, a label with a print length of 50 mm and a height covering 4 print heads is opened.
For different formats, set up the label as described in “LABEL SETTINGS” on page 13.

Fig. 7_63: Creating a New Label

7.1.2 Changing Label Size

3. The label size can be changed by dragging the label edge pointer to the required 
position. Refer to “LABEL SETTINGS” on page 13 for additional details.

Fig. 7_64: Changing the Label Dimensions Manually

NOTE
In UTF-8 mode, the label will be saved as *.xml (UTF-8). In ASCII mode, the
label will be saved as either *.lbl (A.1.23) or *.xml (ASCII).

NOTE
The user can set the number of printheads from the Edit>Label Settings.
This shows the print area of the label.

The label bottom pointer can be used to change the number of printheads.

NOTE
The user can open more than one editor window at the same time.
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7.1.3 Inserting Objects

7.1.3.1 Inserting Text Field

4. Select Insert > Text and type “Wolke Label Creator” in the Text field. Change the 
Text height to 3.0.

Fig. 7_65: Insert Text Field

5. Set the Field properties and Position as per the below image.

Fig. 7_66: Insert Text Field

NOTE
The user can set the access parameter either to Variable field or User
Editable. The user can also select both the options.

Variable field is set to apply dynamic text insertion, for example batch codes,
product names, and other text jobs.

User editable is used to provide editable access to the user.
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6. Click on OK. Now the text is inserted in the Label.

Fig. 7_67: Text Field

For additional details refer to “Insert Text Field” on page 20.

7.1.3.2 Inserting Date Field

7. Select Insert > Date.

Fig. 7_68: Insert Date Field

NOTE
The user can set the position of the objects in two ways:

1. By dragging and dropping the field at the required position in the design
area.

2. Inserting the X, Y coordinates value in the properties window.

NOTE
The user can change the text properties by double clicking on the inserted
text.
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8. Set the Date format to %d.%n.%Y and Position as per the below image. Change 
the Text height to 3.0.

Fig. 7_69: Insert Date Field Parameters

9. Click on OK. Now the date is inserted in the Label.

Fig. 7_70: Date Field

For additional details refer to “Insert Date Field” on page 22.

NOTE
The user can set the access parameters to User Editable.

User editable is used to provide editable access to the user.

NOTE
The user can change the date properties by double clicking on the inserted
date.
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7.1.3.3 Inserting Barcode

10. Select Insert > Barcode. Click on the EAN13.

Fig. 7_71: Insert Barcode Object

11. Set the Position as per the below image.

Fig. 7_72: Insert Barcode Object
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12. Click on OK. Now the barcode is inserted in the Label.

Fig. 7_73: Barcode Object

For additional details refer to “Insert Barcode Object” on page 34.

7.1.3.4 Inserting Bitmap

13. Select Insert > Bitmap.

Fig. 7_74: Bitmap Object

14. Click on Bitmap selection icon and browse for the required image.
15. Select the file and click Open.

NOTE
The input mask for the barcode Code25i provides the five standard field types
(text field, date, time, counter and shift code) as in the other barcodes
(example, EAN 128, Code 128).
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16. Set the position of the bitmap as shown in the figure.

Fig. 7_75: Bitmap Object

17.  Click on OK. Now the bitmap image is inserted in the Label.

Fig. 7_76: Bitmap Object

For additional details refer to “Insert Bitmap” on page 33.

NOTE
The user can insert only .bmp files.
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7.1.4 Saving Label

The user can save the label by clicking on the File > Save. If the user wants to save the label
with a new name, click on the File > SaveAs.

Now the label is ready for printing.

Fig. 7_77: Select Mode

NOTE
The user can save the same label as *.xml or *.lbl file format by selecting the
required mode UTF-8 or ASCII.

NOTE
The user can change the object properties by double clicking on the inserted
object.
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7.2 Zoom

To Zoom-In or Zoom-Out the label, do one of the following:

• Select Zoom-In or Zoom-Out in the main menu View.
• Click the appropriate button in the toolbar.
• Scroll in the label using the mouse wheel.

7.2.1 Cut - Copy - Paste

To cut or copy an object in an opened label, do one of the following:

• Select Cut or Copy from the main menu Edit.
• Click the appropriate button in the toolbar.

To paste the cut or copied object, 

• Select Paste from the main menu Edit.
• Click the appropriate button in the toolbar.

NOTE
The Paste function described above always inserts only the last object which
has been added to the clipboard.

NOTE
Right click on the mouse also makes these functions available in the window.
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8 M600 COMMUNICATION

8.1 Controller Connection

Fig. 8_78: Settings – Controller Connection

To connect your controller, enter the IP Address and port address (for ASCII mode, enter
ASCII TCP Port and for UTF-8 mode, enter UTF-8 TCP Port).
These can be found in both Webserver System Settings > Network Parameter and on the
controller home screen.

Fig. 8_79: Connection m600-PC via TCP/IP

NOTE
Settings are retained but it is necessary to connect to the controller each time
either when Label Creator application is opened or when mode is changed
between ASCII and UTF-8.
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8.2 Loading Labels from the Controller

Fig. 8_80: Loading from Controller

After having configured the interface to your printer, you can open a label directly from the
printer in the Wolke Label Creator.

To open a label, select in the main menu File > Load from controller. The Label files on
controller window opens.

Fig. 8_81: m600 Communication Window 
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Select the corresponding label and click on the button Ok.

Fig. 8_82: Communication Window 

The selected label is opened in the Wolke Label Creator.
If a label exists already on your computer, the following query appears:

Fig. 8_83: Replace File

NOTE
For download from the controller to the PC, the Wolke Label Creator software
creates a folder in which the labels are saved. This folder is created in the
following path:

My Documents\Label Creator\data.
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8.3 Saving Labels to the Controller

Fig. 8_84: Saving to Controller

To upload a label to your controller, the label must be opened in the Wolke Label Creator. 

Select in the main menu File > Upload to controller. After selecting this function, the
following query appears:

Fig. 8_85: Loading to m600

NOTE
If a label or a bitmap integrated in the label under the same name exists
already on your controller, the system prompts whether to overwrite the
existing label or the bitmap integrated in the label.
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8.4 Altering Controller Settings

m600_oem settings window allows to change the system, printhead, Interface, I/O and
message settings.

Fig. 8_86: m600 OEM Settings - System Settings

The default values of the parameters are shown in the below table.

NOTE
The m600_oem settings is not available in ASCII mode. 

Menu Menu Item Value (Default Settings)

System settings

Number of print heads 4

Shaft encoder line A

Low ink warning off

Print memory refresh off

Flush variable buffer off

Product distance ignore

Print trigger without data ignore

Perpetuo print mode off

Pulses 12500

Ink level 0

Idle time (sec) 300

Remove cartridge error

Exceeding product speed warning

Backlight power off(min) 30

Speed 200

NOTE
Perpetuo Print Mode pairs two printheads so that the cartridge can be
replaced without stopping the system.
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Fig. 8_87: m600 OEM Settings - Print head Settings

The default values of the parameters are shown in the below table.

Menu Menu Item Value (Default Settings)

Print head settings

Print head 1

Sensor PZ1(Photoelectric Sensor)

Sensor distance (mm) 20.00

Rev sensor PZ1(Photoelectric Sensor)

Rev sensor distance (mm) 170.00

Position normal

Mirroring normal

Print direction R-L

Ink type 5

Temp register on

Print head 2

Sensor PZ1(Photoelectric Sensor)

Sensor distance (mm) 50.00

Rev sensor PZ1(Photoelectric Sensor)

Rev sensor distance (mm) 140.00

Position normal

Mirroring normal

Print direction R-L

Ink type 5

Temp register on

Print head 3

Sensor PZ1(Photoelectric Sensor)

Sensor distance (mm) 80.00

Rev sensor PZ1(Photoelectric Sensor)

Rev sensor distance (mm) 110.00

Position normal

Mirroring normal

Print direction R-L

Ink type 5

Temp register on
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Print head 4

Sensor PZ1(Photoelectric Sensor)

Sensor distance (mm) 110.00

Rev sensor PZ1(Photoelectric Sensor)

Rev sensor distance (mm) 80.00

Position normal

Mirroring normal

Print direction R-L

Ink type 5

Temp register on

Print head 5

Sensor PZ1(Photoelectric Sensor)

Sensor distance (mm) 140.00

Rev sensor PZ1(Photoelectric Sensor)

Rev sensor distance (mm) 50.00

Position normal

Mirroring normal

Print direction R-L

Ink type 5

Temp register on

Print head 6

Sensor PZ1(Photoelectric Sensor)

Sensor distance (mm) 170.00

Rev sensor PZ1(Photoelectric Sensor)

Rev sensor distance (mm) 20.00

Position normal

Mirroring normal

Print direction R-L

Ink type 5

Temp register on

Menu Menu Item Value (Default Settings)
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Fig. 8_88: m600 OEM Settings - Interface Settings

The default values of the parameters are shown in the below table.

Menu Menu Item Value (Default Settings)

Interface settings

DHCP off

IP-Address 192.168.1.2

Gateway 192.168.1.1

Netmask 255.255.255.0

ASCII port 34567

UTF-8 port 34568
Wolke Label Creator
16 December 2016 Page 66 of 69 Revision AC



Fig. 8_89: m600 OEM Settings - Camera Settings

The default values of the parameters are shown in the below table.

Menu Menu Item Value (Default Settings)

Camera settings

sensor PZ1(Photoelectric Sensor)

camera trigger disable

camera distance (mm) 0.00

clear fifo off

expeller trigger disable

expeller distance (mm) 0.00

camera good signal active low
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Fig. 8_90: m600 OEM Settings - IO Settings

The default values of the parameters are shown in the below table.

Menu Menu Item Value (Default Settings)

IO settings

EXt input1 activate m600

EXt input2 deactivate m600

EXt input3 change of cartridge

EXt input4 pm refresh

Ext output 1 print ready

Ext output 2 error

Ext output 3 lowink alarm

Ext output 4 1_print done
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Fig. 8_91: m600 OEM Settings - Message Settings

The default values of the parameters are shown in the below table.

Menu Menu Item Value (Default Settings)

Message settings

Send periodically (sec) unchecked

Send on event change checked

Status unchecked

Alarm unchecked

Warning unchecked

Error unchecked

Buffer low unchecked

Variable index unchecked

Print done unchecked
Wolke Label Creator
Revision AC Page 69 of 69 16 December 2016


	1 OVERVIEW
	2 INSTALLATION
	2.1 Prerequisites – System Requirements
	2.2 Installing the Wolke Label Creator

	3 CREATOR WINDOW
	3.1 Main Menu
	3.1.1 File
	3.1.2 Edit
	3.1.3 Insert
	3.1.4 View
	3.1.5 Settings
	3.1.6 Windows
	3.1.7 Help

	3.2 Toolbar
	3.3 Mode information
	3.4 Editor window
	3.5 Object Directory

	4 LEGACY FILE CONVERTER
	5 LABEL SETTINGS
	5.1 Label Settings
	5.1.1 Size and Resolution
	5.1.2 Label Dimensions
	5.1.3 Additional Settings
	5.1.4 Spitting Settings


	6 INSERTING OBJECTS
	6.1 Insert Text Field
	6.1.1 Master Field
	6.1.1.1 To Link to a Master Field


	6.2 Insert Date Field
	6.2.1 Date Field
	6.2.2 Master Field
	6.2.2.1 To Link to a Master Field

	6.2.3 User Defined Date Format

	6.3 Insert Time Field
	6.3.1 Time Field Properties
	6.3.2 User Defined Time Format

	6.4 Insert Shift Field
	6.4.1 Shift Field Properties

	6.5 Insert Counter Field
	6.5.1 Counter Field Properties
	6.5.2 Advanced
	6.5.3 Master Field
	6.5.3.1 To Link to a Master Field


	6.6 Insert Combi Field
	6.6.1 Combi Field Properties

	6.7 Insert Bitmap
	6.7.1 Bitmap Properties

	6.8 Insert Barcode Object
	6.8.1 Barcodes - EAN13, EAN8, UPC - A/E
	6.8.1.1 General Properties

	6.8.2 Codabar
	6.8.2.1 General Properties

	6.8.3 Barcodes - Code39, Code25i
	6.8.3.1 General Properties
	6.8.3.2 Barcode Text

	6.8.4 Barcodes - Code128, Ean128
	6.8.4.1 General Properties
	6.8.4.2 Barcode Text

	6.8.5 Datamatrix
	6.8.5.1 General Properties

	6.8.6 GS1 Databar
	6.8.6.1 General Properties
	6.8.6.2 Barcode Text

	6.8.7 QR Code
	6.8.7.1 General Properties

	6.8.8 Barcodes - Postnet, IMB
	6.8.8.1 General Properties


	6.9 Positioning Objects
	6.9.1 Object Editor
	6.9.2 Editor Window


	7 GENERAL SETTINGS
	7.1 Creating a Label
	7.1.1 Creating a New Label
	7.1.2 Changing Label Size
	7.1.3 Inserting Objects
	7.1.3.1 Inserting Text Field
	7.1.3.2 Inserting Date Field
	7.1.3.3 Inserting Barcode
	7.1.3.4 Inserting Bitmap

	7.1.4 Saving Label

	7.2 Zoom
	7.2.1 Cut - Copy - Paste


	8 M600 COMMUNICATION
	8.1 Controller Connection
	8.2 Loading Labels from the Controller
	8.3 Saving Labels to the Controller
	8.4 Altering Controller Settings


